Dashboard and API Degraded Performance
Incident Report for Samsara Public
Resolved
From 12:27pm PST to 5:21pm PST on January 24 2020 we experienced an issue that impacted the performance of our cloud based dashboard, our API and the Samsara Driver App, impacting some of our customers. This issue was related to a service disruption of an underlying Amazon Web Services service which has now been restored by AWS (AWS status page here). This issue has now been fully resolved for all Samsara users.

No data was lost as a result of this incident

We apologize for any impact this incident had on your operations. Our engineering team is doing everything they can to learn from this event and use these learnings to further improve the reliability of our systems. Please feel free to reach out to us at samsara.com/support if you have any questions or concerns.
Posted Jan 24, 2020 - 18:16 PST
Monitoring
The underlying service disruption with a specific Amazon Web Services service we use has been resolved. We expect full platform functionality to be restored shortly, and will closely monitor performance while the system recovers. We do not expect any data loss as a result of this incident.
Posted Jan 24, 2020 - 16:17 PST
Update
We have traced the root cause of this service disruption to an underlying outage with Amazon Web Services (AWS status page here). We are both working directly with AWS to expediently resolve the underlying issue, and in parallel working to mitigate the impact of this outage on our own internal Samsara systems. All data continues to be recorded, and we do not expect any data loss as a result of this incident.
Posted Jan 24, 2020 - 15:36 PST
Identified
Engineering has identified the root cause and is actively working to resolve the issue.
Posted Jan 24, 2020 - 15:07 PST
Update
We are continuing to investigate an issue that is impacting the Fleet Overview page, the Samsara Driver App, and the Fleet Routing page. API performance has been restored.
Posted Jan 24, 2020 - 14:14 PST
Update
We are continuing to investigate this issue.
Posted Jan 24, 2020 - 13:44 PST
Investigating
We are currently investigating an issue that is impacting API, Routing, and the Cloud Dashboard for some customers.
Posted Jan 24, 2020 - 13:32 PST
This incident affected: Cloud Dashboard, GPS / Location / Map, HOS / Compliance, Apps / Integrations / APIs, Safety / Cameras, Routing, Alerts, DVIR, Maintenance, Documents, Messaging, Sensors, and Industrial.