Safety - Safety Multi-branching Workflows delayed in delivery

Incident Report for Samsara Public

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Jul 03, 2025 - 20:21 PDT

Identified

Our engineering team has identified the root cause and is actively working to resolve the issue.
Posted Jul 03, 2025 - 18:26 PDT

Investigating

We are currently experiencing an issue where Safety Multi-branching Workflows are delayed for a subset of customers. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Jul 03, 2025 - 16:32 PDT
This incident affected: Cloud Dashboard and Safety / Cameras.