US Organizations - HOS pages and features failing in Driver App and Cloud

Incident Report for Samsara Status

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Jul 14, 2026 - 10:26 PDT

Identified

At this time we have identified that Samsara Driver App and Samsara Cloud HOS pages and features have observed failures or delays in processing. Our engineering has identified the root cause and is actively working to resolve the issue.
Posted Jul 14, 2026 - 10:10 PDT

Investigating

We are currently experiencing an issue with the HOS module, where some customers may see delays in driver log processing and status updates in Dashboard. Our engineering team has identified the likely cause and is actively working to fully resolve the issue. For real-time updates, please visit https://www.samsarastatus.com/
Posted Jul 14, 2026 - 09:47 PDT
This incident affected: HOS / Compliance.