Cloud Dashboard Availability

Incident Report for Samsara Status

Update

We are currently in the active recovery phase:
-Customers in the US should now see full recovery.
-Services in Canada and the EU are stabilizing. Some customers in Canada and the EU may continue to experience intermittent issues accessing the cloud dashboard. If this occurs, please refresh the page and try again.
We expect full service restoration soon. Thank you for your patience. We will provide additional updates as needed.
Posted Feb 23, 2026 - 13:24 PST

Update

We are currently in the active recovery phase. Some users may experience intermittent issues accessing the cloud dashboard. If this occurs, please refresh the page and try again. We expect full service restoration within the next few minutes. We appreciate your patience and will share further updates as needed.
Posted Feb 23, 2026 - 13:06 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 12:50 PST

Identified

Our engineering team has identified the cause for availability issues in Samsara Cloud, and recovery efforts are now underway. We’ll continue to provide updates as progress is made.
Posted Feb 23, 2026 - 12:42 PST

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 11:39 PST

Investigating

We are currently investigating this issue
Posted Feb 23, 2026 - 11:39 PST
This incident affects: US Cloud Dashboard, European Cloud Dashboard, Canada Cloud Dashboard, and Apps / Integrations / APIs.