Safety Features Not Visible for Tag-scoped Admins

Incident Report for Samsara Status

Resolved

The issue affecting access to the safety-related areas in the UI for tag-scoped admin permissions has been resolved. Full access to all safety features has been restored.

We appreciate your patience while our team worked to resolve this issue.
Posted Mar 06, 2026 - 09:05 PST

Update

We are actively working to restore full access to all safety features.

As a temporary workaround, impacted users can retrieve videos from a vehicle’s trip timeline by selecting “Retrieve Video.
Posted Mar 06, 2026 - 08:36 PST

Investigating

We are currently investigating an issue where admins using custom roles with tag-scoped permissions are unable to access the Safety Inbox, Safety tab, and other safety-related areas in the UI. Our team is actively working to identify the root cause and restore expected access.
Posted Mar 06, 2026 - 07:23 PST
This incident affected: Safety / Cameras.