EU Cloud - New dashboards unable to be created

Incident Report for Samsara Status

Update

We are continuing to investigate the issue impacting the creation of new EU Cloud Dashboards. All existing EU Dashboards are not impacted by this issue.
Posted Jul 15, 2026 - 13:15 PDT

Investigating

We are currently experiencing an issue where new cloud dashboards in the EU region are unable to be created. Our engineering team is actively investigating and working to resolve this as quickly as possible.
Posted Jul 15, 2026 - 12:09 PDT
This incident affects: European Cloud Dashboard.