Incorrect odometer readings on work orders

Incident Report for Samsara Status

Identified

The root cause of the incorrect odometer readings on work orders has been identified. Our engineering team is currently deploying a fix and updating affected values
Posted Sep 23, 2026 - 13:23 PDT

Update

Our engineering team is actively investigating the issue that may cause inflated odometer readings on the Work Orders page for some customers. We are working to resolve this as quickly as possible. For updates: https://www.samsarastatus.com/
Posted Sep 23, 2026 - 09:17 PDT

Investigating

We are currently experiencing an issue where odometer readings may be inflated in the Work Orders page. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Sep 23, 2026 - 06:59 PDT
This incident affects: Maintenance.