We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Jul 29, 2025 - 07:46 PDT
Update
The Samsara dashboard in the EU is now loading but we are still seeing some pages that are taking longer than expected to load. Our Engineering team is continuing to monitor this
Posted Jul 29, 2025 - 06:06 PDT
Monitoring
Our Engineering team has deployed a fix and is now monitoring to confirm performance is back to normal.
Posted Jul 29, 2025 - 05:37 PDT
Update
Our team is continuing to work on a fix for this issue
Posted Jul 29, 2025 - 05:15 PDT
Identified
Engineering has identified the root cause and is actively working to resolve the issue.
Posted Jul 29, 2025 - 04:52 PDT
Investigating
We are currently experiencing an issue where the Samsara dashboard is not loading for customers in the EU. Our engineering team is actively investigating this