EU Cloud – Enterprise Dashboard Overview Page Loading Issues

Incident Report for Samsara Status

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Mar 25, 2026 - 05:53 PDT

Identified

Engineering has identified the root cause and is actively working to resolve the issue.
Posted Mar 25, 2026 - 04:48 PDT

Investigating

We are currently investigating an issue where Enterprise customers in the EU are unable to load the Overview Page in their dashboard. Our engineering team is actively working to resolve this as quickly as possible. We apologise for any impact this may have on your operations.
Posted Mar 25, 2026 - 02:53 PDT
This incident affected: European Cloud Dashboard.