Safety - Safety Events missing from Safety Inbox

Incident Report for Samsara Public

Resolved

We have confirmed that the issue is now resolved. Please contact samsara.com/help if you have any questions or concerns.
Posted Jul 02, 2025 - 14:12 PDT

Update

Our engineering team is continuing to investigate this issue.
Posted Jul 02, 2025 - 08:46 PDT

Update

Our engineering team is continuing to investigate this issue.
Posted Jul 02, 2025 - 06:58 PDT

Update

Our engineering team is continuing to investigate this issue.
Posted Jul 02, 2025 - 04:58 PDT

Investigating

We are currently investigating an issue that is impacting Safety Event's ability to display in the Safety Inbox for some customers.
Posted Jul 02, 2025 - 04:11 PDT
This incident affected: Cloud Dashboard and Safety / Cameras.