IFTA Mileage Report Service Interruption
Incident Report for Samsara Public
Resolved
This incident has been resolved.
Posted Jan 02, 2020 - 14:47 PST
Identified
We are currently experiencing a service interruption to our IFTA Mileage Report in the Dashboard. Engineering has identified the root cause and is actively working to resolve the issue.
Posted Jan 02, 2020 - 14:37 PST
This incident affected: Cloud Dashboard.