Harsh events settings page crashing
Incident Report for Samsara Public
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 19:20 PDT
Investigating
We are currently investigating this issue.
Posted Mar 20, 2024 - 18:51 PDT
This incident affected: Safety / Cameras.