Loss of device connectivity to the Samsara Cloud in the EU Region

Incident Report for Samsara Status

Resolved

This incident has been resolved. Thank you so much for your patience and Co-Operation!
Posted Nov 25, 2025 - 01:41 PST

Monitoring

A fix has been implemented and we are monitoring the status.
Posted Nov 25, 2025 - 01:28 PST

Update

We are actively collaborating with our engineering team to address this issue and ensure the page remains updated.
Posted Nov 25, 2025 - 00:56 PST

Identified

We have recognized a problem that is impacting device connectivity to the Samsara Cloud in the EU Region. We sincerely apologize for any disruption this may be causing to your operations. Our engineering team is currently investigating the issue and is dedicated to resolving it as swiftly as possible.
Posted Nov 25, 2025 - 00:08 PST
This incident affected: GPS / Location / Map and Safety / Cameras.