Samsara Cloud - Fuel and Maintenance feature missing on dashbaord

Incident Report for Samsara Status

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Oct 15, 2025 - 02:51 PDT

Investigating

We are currently investigating an issue that is impacting Fuel and Maintenance icons are missing from the toolbar on Samsara Cloud for some customers.
Posted Oct 15, 2025 - 02:22 PDT
This incident affected: Cloud Dashboard, European Cloud Dashboard, and Maintenance.