WhatsApp messages failing to send
Incident Report for Samsara Public
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 15:53 PDT
Investigating
We are currently investigating this issue.
Posted Apr 17, 2024 - 13:00 PDT
This incident affected: Alerts and Messaging.