Work orders failing to load for some customers.

Incident Report for Samsara Status

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Jul 08, 2026 - 09:06 PDT

Monitoring

Our engineering team has resolved the issue and is now monitoring to confirm performance is back to normal.
Posted Jul 08, 2026 - 06:00 PDT

Investigating

We are currently experiencing an issue with work orders failing to load, where some customers may be unable to access work orders in Maintenance. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Jul 08, 2026 - 05:42 PDT
This incident affected: Maintenance.