Retrieved media playback disruption.

Incident Report for Samsara Status

Identified

We have identified the cause of an issue affecting video playback, which may cause problems when playing footage from the library as well as from the Safety inbox for some customers.

Our engineering team is implementing a fix and monitoring the recovery closely. Please contact http://samsara.com/help if you have any questions or concerns. We apologise for any inconvenience this may have caused.
Posted Sep 14, 2026 - 08:24 PDT

Investigating

We are investigating an issue affecting Retrieved Footage playback which may cause problems with Media playback for some customers.

Our engineering team is actively working to identify the cause and restore the service to normal. Please contact http://samsara.com/help if you have any questions or concerns. We apologise for any inconvenience this may have caused.
Posted Sep 14, 2026 - 06:52 PDT
This incident affects: US Cloud Dashboard, European Cloud Dashboard, Canada Cloud Dashboard, and Safety / Cameras.