EU Cloud Dashboard, Mobile App, and API disruption

Incident Report for Samsara Status

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 22:57 PDT

Investigating

We are currently investigating an issue causing a drop in Dashboard page availability, delays in page loading, and API disruptions.
Posted Apr 09, 2026 - 22:18 PDT
This incident affected: European Cloud Dashboard and Apps / Integrations / APIs.