Our Engineering team has deployed a fix for the incorrect page labels. While most areas are resolved, we are continuing to update a few remaining residual pages.
Posted Sep 25, 2026 - 10:21 PDT
Identified
We have identified the cause of incorrect or missing translations for customers using languages other than English. A fix is being applied. Some residual translation issues may still appear while we complete the remediation, and we are working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Sep 25, 2026 - 08:10 PDT
Investigating
We are currently investigating an issue that is impacting dashboard labels for some customers using languages other than English. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Sep 25, 2026 - 07:29 PDT
This incident affects: US Cloud Dashboard, European Cloud Dashboard, and Canada Cloud Dashboard.