Dashboards and fleet list pages are timing out/slow to load

Incident Report for Samsara Status

Update

We are continuing to investigate the issue
Posted Jun 30, 2026 - 09:25 PDT

Update

We are currently experiencing an issue that is impacting some pages and tools, like the overview page and site navigation menu. Our engineering team is actively investigating and working to resolve this as quickly as possible.
Posted Jun 30, 2026 - 07:04 PDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 06:14 PDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 06:14 PDT

Investigating

We are currently investigating an issue that is impacting the overview page for some Customers.
Posted Jun 30, 2026 - 05:57 PDT
This incident affects: US Cloud Dashboard, European Cloud Dashboard, and Canada Cloud Dashboard.