U.S. Device Connectivity and Dashboard Access Issues

Incident Report for Samsara Status

Resolved

The issue affecting U.S. device connectivity and intermittent dashboard access has been resolved. Services have returned to normal operation. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Jul 24, 2026 - 06:57 PDT

Monitoring

We have seen connectivity recover back to normal levels. The external party has acknowledged the issue and indicated services should be back to normal. Our engineering team is continuing to monitor closely to confirm full stability before marking this as fully resolved. For real-time updates, please visit samsarastatus.com.
Posted Jul 24, 2026 - 06:16 PDT

Update

We are continuing to investigate this issue.
Posted Jul 24, 2026 - 05:14 PDT

Investigating

We are currently experiencing an issue affecting U.S. device connectivity and dashboard access. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Jul 24, 2026 - 05:09 PDT
This incident affected: US Cloud Dashboard, European Cloud Dashboard, and Canada Cloud Dashboard.