Degraded Performance for certain standard reports

Incident Report for Samsara Status

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 09:29 PDT

Identified

Engineering has identified the root cause and is actively working to resolve the issue.
Posted Jun 05, 2026 - 08:39 PDT

Investigating

We are currently investigating an issue that is impacting the standard reporting or some customers.
Posted Jun 05, 2026 - 08:07 PDT