Devices page crashes and returns error

Incident Report for Samsara Status

Resolved

We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Apr 08, 2026 - 08:35 PDT

Identified

Engineering has identified the root cause and mitigated the issue for some regions. We are still actively working to fully resolve it for all affected customers.
Posted Apr 08, 2026 - 07:22 PDT

Update

Engineering has identified the root cause and is actively working to resolve the issue.
Posted Apr 08, 2026 - 04:52 PDT

Update

The issue affecting the Devices page within the Dashboard Settings is still ongoing for some customers. Our engineering team remains actively engaged.
Posted Apr 08, 2026 - 02:19 PDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2026 - 00:21 PDT

Investigating

We're currently investigating an issue where the Devices page within the Dashboard Settings fails to load, returning a "We're sorry, an error occurred" message.
Posted Apr 08, 2026 - 00:21 PDT
This incident affected: US Cloud Dashboard, European Cloud Dashboard, and Canada Cloud Dashboard.