We have confirmed that the issue is now resolved. Please contact http://samsara.com/help if you have any questions or concerns.
Posted Sep 22, 2026 - 11:37 PDT
Update
Our Engineering team is actively working to ensure the incorrect classifications are corrected and restore full functionality.
Posted Sep 22, 2026 - 09:27 PDT
Update
Our Engineering team is actively working to resolve the issue and restore full functionality.
Posted Sep 22, 2026 - 07:54 PDT
Identified
Engineering has identified the root cause and is actively working to resolve the issue.
Posted Sep 22, 2026 - 05:28 PDT
Investigating
We are currently experiencing an issue with HOS property classification, where some drivers in Canada may be identified as being in the United States. Our engineering team is actively investigating and working to resolve this as quickly as possible. For real-time updates, please visit https://www.samsarastatus.com/
Posted Sep 22, 2026 - 04:57 PDT
This incident affected: US Cloud Dashboard and Canada Cloud Dashboard.