Samsara dashboard page load

Incident Report for Samsara Public

Resolved

This incident has been resolved.
Posted Jul 25, 2024 - 00:51 PDT

Monitoring

The cloud dashboard has recovered, and users are able to access and run updates. We will continue to monitor the fix.
Posted Jul 24, 2024 - 23:56 PDT

Update

We are currently experiencing an issue that is preventing users from making updates to the Cloud Dashboard. We apologize for any impact this is having on your operations.
Posted Jul 24, 2024 - 23:09 PDT

Investigating

We are currently investigating the issue
Posted Jul 24, 2024 - 21:45 PDT
This incident affected: Cloud Dashboard, Apps / Integrations / APIs, and Routing.